6 mei 2010

Problemen met mijn bezoekers

Nou ja, niet echt problemen met die bezoekers zelf, maar met het volgen van hun bezoekbewegingen door middel van statistieken. Ik gebruik daarvoor Google Analytics en Clicky en beide tellers geven sinds gisteren geen sjoege meer, nadat ik de nodige code in de html van het nieuwe sjabloon had verwerkt.

Vreemd is dat Google Analytics wel aangeeft dat er gegevens worden ontvangen en dat er al met al een stuk of drie bezoeken door beide tellers zijn geregistreerd. In de broncode van de blog zie ik dat de code ook is meegenomen vanuit het sjabloon. Maar goed, iets is er dus niet goed.

Op het helpforum van Blogger las ik dat het posten van een nieuw bericht misschien de oplossing is. Eventjes proberen dus, vandaar dit bericht.

Dit is dus een van de redenen waarom ik niet graag met sjablonen klooi. Altijd gedoe!

8 opmerkingen:

  1. Ik ben er in elk geval, benieuwd of je tellers me ook registreren! Mooie nieuwe vormgeving hoor, lekker zomers.

    BeantwoordenVerwijderen
  2. Mijn beste gok is dat er iets mis is met de nesting van de HTML-elementen. In je code zie ik bij de archief2.0 links enorm veel slash lis achter Twitter staan. Ik kan me voorstellen dat de browser zich daar in verslikt.

    BeantwoordenVerwijderen
  3. @Lineke: Dank je. Of specifiek jij bent geregistreerd, dat weet ik niet. In ieder geval zijn er weer bezoeken geregistreerd, maar alleen nog maar door Google Analytics.

    @Yvette: Tja, al die andere list items zijn niet afgesloten, om tussenregels te vermijden. Blijkbaar gooit Blogger er dan zelf maar wat tags in om de boel alsnog netjes te sluiten. Deze widget zat trouwens ook precies zo in de oude blog.

    Google Analytics lijkt nu weer te werken. Ik heb wel de tracking-code opnieuw opgehaald bij Blogger. Die andere kwam rechtstreeks uit m'n oude blog. Clicky geeft nog steeds niks, dus misschien moet ik die code ook eens updaten.

    Ik blijf wat aanrommelen, maar in stapjes, zodat ik weet wat ik doe en wat het effect daarvan is. Dank voor je feedback!

    BeantwoordenVerwijderen
  4. @Yvette: Heb de tabel in die widget toch maar even aangepast, maar Clicky is nog steeds niet happy met m'n template...

    BeantwoordenVerwijderen
  5. Niet gesloten tags is vragen om problemen als je XHTML gebruikt. Mijn advies zou zijn om gewoon alle LI's te sluiten en dan in CSS de afstand te regelen.

    Het zou ook kunnen dat Clicky zich verslikt in de tientallen syntax-fouten in de pagina's. Daarom zou ik je aanraden om de template te voorzien van een doctype declaratie voor XHTML 1.0 transitional, dat komt waarschijnlijk het dichtst in de buurt bij wat je doet.

    BeantwoordenVerwijderen
  6. @Yvette: Dat scherm kleurt aardig rood... Toch eens naar kijken vanavond!

    Inmiddels is trouwens ook Clicky weer alive, nadat ik de code had vernieuwd. Ik denk dus dat dit in beide gevallen de truuk is geweest.

    Eerder dacht ik daar niet aan, aangezien de oude code - ik wist niet eens dat er een nieuwe was - in m'n oude template prima functioneerde. Blijkbaar merken Clicky en Google Analytics echter dat er iets is veranderd aan de site (onderbreking van de tracking natuurlijk) en zien ze het vervolgens als een nieuwe aanmelding of zoiets, die met de nieuwe code moet werken. Zo faseren ze het gebruik van de oude code natuurlijk uit.

    Normaal krijg je van zoiets toch bericht en normaal ben ik daar erg secuur in, maar dit heb ik klaarblijkelijk gemist. Ook op de helppagina's van de beide providers kwam ik hier niks over tegen, maar misschien keek ik er overheen.

    In ieder geval werkt het weer. Dank voor je hulp! Naar die declaratie van het doctype ga ik zeker kijken.

    BeantwoordenVerwijderen
  7. En ondertussen is je Meeb nog steeds verdwenen...

    BeantwoordenVerwijderen
  8. @Richard: Nee hoor, alleen is de chatbox verplaatst naar de nieuwe contactpagina.

    Dat heeft wat nadelen, maar die wogen met het weinige gebruik van de chat niet op tegen de langere laadtijd van de weblog, die de chatbox met zich meebracht.

    BeantwoordenVerwijderen